1980 El camino build

preston.stewart995

Not-quite-so-new-guy
Jan 7, 2014
21
5
3
TEXAS
#1
V__0001.jpg
Here's my 1980 el camino , its under construction as of now .

(331) 327 bored .30 over '(large journal)
lunati flat tappet cam
comp crane aluminum rockers
Gm fast burn aluminum heads
edelbrock rpm intake
moroso oil pan & pickup
hardend rods
steel crank
new gaskets all around
new harmonic balancer
new fuel pump


WP_000030.jpg




Motor Finally put in now time to clean her up and add headers and carb

WP_000112.jpg




added hooker headers and 650 holley double pump, taylor wires, and serptine set up from my old motor, Don't worry I plan to update the serptine set up, just tryning to get her up and running. Debating on Whether I should get rid of the a/c but I stay in texas, and a/c is pretty much a life saver. May still get rid of it

elcoooo.jpg



another look at the el co (steel cowl hood)

el co tho.jpg
 
Last edited:

MrHernandez

G-Body Guru
May 25, 2009
559
5
18
36
Jackson,TN
#2
Looking good. What are your other plans for it? Repaint, interior, suspension?
 

preston.stewart995

Not-quite-so-new-guy
Jan 7, 2014
21
5
3
TEXAS
#3
interior & suspension is definitely on my todo list but as of now,im working on the rearend then brakes, suspension and last but not least paint and interior,
 

thrasher

Greasemonkey
Nov 12, 2013
120
0
0
#4
Pretty good so far.
I like the Z stripes on the hood but on the top is a bit much, please tell me they didn't put them on the tailgate.
 

the ghoul

Master Mechanic
Dec 18, 2012
252
11
18
#5
Killer!
Pappy had an 80 he bought brand new in 81. Had it till 99.
The one that got me addicted to these.
Keep up the good work
 

preston.stewart995

Not-quite-so-new-guy
Jan 7, 2014
21
5
3
TEXAS
#8
rear roll pan installed and started the body work

WP_000005.jpg




front bumper installed and new front clip

WP_000041.jpg
 
Last edited:

84cutspreme

Royal Smart Person
Jun 4, 2009
1,014
28
48
#9
Just fyi, I have same serpentine belt setup and had reverse rotation mech fan and thermal clutch...had shaft on the water pump snap. I replaced it with electric fans. May have been a freak thing or defect in the pump, but I'm not taking any chances
 

preston.stewart995

Not-quite-so-new-guy
Jan 7, 2014
21
5
3
TEXAS
#10
Got el co back from transmission shop, Started wiring up headlights

elco3.jpg





Next to the vette

WP_000263.jpg






tailights installed


elco2.jpg
 
Last edited:

Similar threads

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot GBodyParts Mike's Montes P-S-T UMI Performance

contact [email protected] for info on becoming a sponsor