1987 TBI 454 Suburban... It Runs! Kinda.

MrSony

MrSony

Comic Book Super Hero
Nov 15, 2014
4,575
2,862
113
Des Moines, Iowa
The thing doesn't run long enough to check anything with a temp gun. it will run for 20 seconds, stumble and die. and it runs like dog **** the hole time, all the while almost nothing comes out of the exhaust.
 
MrSony

MrSony

Comic Book Super Hero
Nov 15, 2014
4,575
2,862
113
Des Moines, Iowa
Plugged exhaust would also explain all the random vapors coming from everywhere once it shuts off and maybe the massive amounts of ticking and clicking (like an engine cooling down), but i don't think it should be doing it for 3 minutes after running for 20 seconds.
 
pontiacgp

pontiacgp

Canadian Prime Minister
Mar 31, 2006
24,309
9,587
113
Kitchener, Ontario
The thing doesn't run long enough to check anything with a temp gun. it will run for 20 seconds, stumble and die. and it runs like dog **** the hole time, all the while almost nothing comes out of the exhaust.
did you try this yet?...

 
MrSony

MrSony

Comic Book Super Hero
Nov 15, 2014
4,575
2,862
113
Des Moines, Iowa
did you try this yet?...
Doubt it would run long enough to even get a steady signal. It would be erratic at best. It runs like *ss.
 
1bad79

1bad79

G-Body Guru
Dec 3, 2011
794
582
63
Allendale mi
Did you check fuel pressure? And a good way to check exhaust back pressure just simply pull the o2 sensor out and see if it runs when it's unplugged it will just go in to open loop and if it's plugged it will run we do this all the time in automotive and forklift I haven't found as many plugged converters as I used to but that does happen from time to time
 
MrSony

MrSony

Comic Book Super Hero
Nov 15, 2014
4,575
2,862
113
Des Moines, Iowa
I have not checked fuel pressure. Wouldnt there be a code if there was a problem?
And it seems to be drowning itself in fuel. Very strong odor and you can see the injectors going full blast, or at least thats what it seems like, when its idling for a few seconds. That might just be how it acts on a cold engine though...
 
Last edited:
1bad79

1bad79

G-Body Guru
Dec 3, 2011
794
582
63
Allendale mi
Nope no code if there’s not enough fuel psi but it could cause other codes you really need a good scann tool to see what is going on it’s to bad you weren’t closer I have my old snap on brick yet and use it once in a while for stuff like this
 

Similar threads


Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot Mike's Montes P-S-T Southside Machine Performance UMI Performance

contact [email protected] for info on becoming a sponsor

copyright ©2018 Ripp Technical Services, All Rights Reserved.