83 DASH WIRING PROBLEM

MR.CHEVY

Not-quite-so-new-guy
Jan 10, 2022
6
3
On my 83 wagon decided to install full gauge dash from 1984 Monte and get rid of round speedo and fuel gauge only from Malibu . have seen all info and diagrams from Malibu racing .com and still having problems with things not working . is their any where else I can look up the wiring harness colors and connections . greatly appreciated if some one could advice MR.CHEVY

PS. all switches have been changed from idiot lights to gauges .
 

79 USA 1

G-Body Guru
Sep 2, 2011
951
93
Cheektowaga, New York
I've used this pinout diagram when changing from idiot lights to gauges.
Wire Diagram.png

I also recommend cleaning the metal tabs on both the printed circuit as well as cluster connector with a green scotchbrite pad or even a pencil eraser. Also I've used an o-ring pick on the cluster connector metal tabs to raise them slightly assuring good contact.

Just my $.02. Hope this helps.
 
  • Like
Reactions: 1 user

MR.CHEVY

Not-quite-so-new-guy
Thread starter
Jan 10, 2022
6
3
I've used this pinout diagram when changing from idiot lights to gauges.
View attachment 203739

I also recommend cleaning the metal tabs on both the printed circuit as well as cluster connector with a green scotchbrite pad or even a pencil eraser. Also I've used an o-ring pick on the cluster connector metal tabs to raise them slightly assuring good contact.

Just my $.02. Hope this helps.
Thanks every works now , except tach seems to running a little high for engine speed ? 3200 rpm
 
  • Like
Reactions: 1 user

MR.CHEVY

Not-quite-so-new-guy
Thread starter
Jan 10, 2022
6
3
Was it out of a V8 & reading off a V6 or vice versa? If it's a V8 tach on a V8, did you pull the tach filter & installed it?


Chevy tachs didn't have the 6-8 jumper.
dash is from an 84 monte with a v8 (305) installed new tach filter . I read that I should try installing tach without filter to see any difference. thanks to all for your 2cents. MR.CHEVY

P.S. forgot to mention took out the v6 and put in a 454 ..
 

79 USA 1

G-Body Guru
Sep 2, 2011
951
93
Cheektowaga, New York
Thanks every works now , except tach seems to running a little high for engine speed ? 3200 rpm


Where is the red line on the tach? Most of the V-8 tachs I've found have a 5000 red line while SS Monte Carlo tachs have a 5500 red line. I believe the V-6 tach has a 4500 red line.
Below is the V-8 in the 78-79 gauge face with the yellow band starting at about 4700 rpm and the red line at 5000 rpm.

20220609_161300.jpg
This is the 80-85 gauge face with an SS Monte Carlo tach. The orange warning line starts at 4400 rpm and the red line is at 5500 rpm.

P1012082.JPG

I believe this is a set up from a V-6 Car, judging by the tach red line.
v6 tach.jpg
 
Last edited:

MR.CHEVY

Not-quite-so-new-guy
Thread starter
Jan 10, 2022
6
3
Sorry for not getting back sooner , sometimes life gets in the way ! the dash and tach I have is the 80-85 gauge face from an SS Monte Carlo tach 5500 red line . also installed a new dash printed circuit board , but that didn't change anything . tach still runs high ,so I ordered a new printed circuit board for tach to see if that helps . I'll let you all know and thanks again for all your support and info .
 

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot Mike's Montes UMI Performance

Contact Admin@GBodyForum.com for info on becoming a sponsor