84 elco trouble starting

1984elcamino

Not-quite-so-new-guy
Oct 1, 2021
5
3
New to page.Hoping can get help. I recently replaced fuel pump and fuel filter on my 1984 el camino but still having trouble starting. I turn the key and silence nothing happens. Its in my driveway. I have to roll the car down to make it level and after a bit it starts. Once on it runs good. 305 5.0
Any help appreciated.
 
  • Like
Reactions: 1 user

g0thiac

Master Mechanic
Sep 6, 2020
440
43
New to page.Hoping can get help. I recently replaced fuel pump and fuel filter on my 1984 el camino but still having trouble starting. I turn the key and silence nothing happens. Its in my driveway. I have to roll the car down to make it level and after a bit it starts. Once on it runs good. 305 5.0
Any help appreciated.
A new fuel pump and filter for a vehicle that old is not a terribly bad idea, but it won’t fix silence from an engine that doesn’t even come close to trying to start.

If it starts at an angle like you claim it does, my guess is the wire going to the starter is probably just touching the terminals rather than being bolted on. That or it’s having a short against the firewall.

I would check your battery connections too, if theres any corrosion clean it, or cables which are damaged replace them man.
 
  • Agree
Reactions: 1 user

1984elcamino

Not-quite-so-new-guy
Thread starter
Oct 1, 2021
5
3
Ok i checked battery took it to get checked and good. Cables are good. Just replaced the starter and still nothing.
I had my son turn the key and I can hear a light ticking somewhere by the distributor/firewall.
 
  • Like
Reactions: 1 user

g0thiac

Master Mechanic
Sep 6, 2020
440
43
Ok i checked battery took it to get checked and good. Cables are good. Just replaced the starter and still nothing.
I had my son turn the key and I can hear a light ticking somewhere by the distributor/firewall.
Short the starter terminals, using a screwdriver which is insulated or some wire that can jump it.

Because it sounds like the wire going into the dash isn’t doing what it’s supposed to.
 

1984elcamino

Not-quite-so-new-guy
Thread starter
Oct 1, 2021
5
3
Figured it out. It has something to do with the ignition switch. I got in my elco tilted the steering wheel down and it started right up.
Thank u for the help.
 
  • Like
Reactions: 1 user

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck ConsolesDixie Restoration DepotMike's MontesP-S-TSouthside Machine PerformanceUMI Performance

ContactAdmin@GBodyForum.comfor info on becoming a sponsor