Alternator going bad?

Gremlinsteve

Greasemonkey
Mar 6, 2018
240
179
43
48
#1
Reason I'm asking is I just replaced my alternator
It started showing a discharge most of the time on the factory gauge

So I replaced it and I'm showing a discharge still
At idle it's dropping down to 8-9 volts indicated
And at 2500 rpm cruise it shows a 12-12.5 area tops

Measured at battery terminals at idle I'm seeing 12.22 volts

Is the new alternator bad also?
 

melloelky

G-Body Guru
Oct 22, 2017
528
366
63
38
mass
#3
With the engine running carefully take a screwdriver and place it on the back of the case.if the driver is strongly drawn towards the back it's charging.
 

Zspoiler

Apprentice
Jun 3, 2018
89
29
18
61
#4
Take it back f you are not satisfied with it.They can bench test them at the store.And if you still have issues,Then you know its not your altrenator.
 
Aug 8, 2011
5,110
1,914
113
Michigan
#5
I would do all of your testing with a volt meter and test from the output terminal off the back of the alternator and disregard anything your factory gauge tells you
 
Oct 2, 2016
885
557
93
60
#9
make sure you have 12volts to rear of alternator and to red wire that plugs into regulator. Brown wire is turn on so unplug 2 wire connector, start propulsion plant and see if you have 12 volts. With engine running see what your voltage is at the rear output, if it happens to be real high you have an open wire. Rare but something to think about.
If all good bad alternator.
 

Similar threads

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot GBodyParts Mike's Montes P-S-T UMI Performance

contact [email protected] for info on becoming a sponsor