carb guys

wonderboy24

wonderboy24

Royal Smart Person
Jul 10, 2012
1,167
651
113
Davenport, Iowa
#1
i got a question. my moms car a 86 caprice with 305 . she called me up and told me it wouldn't start. so i went to her house and checked it out.i had her turn it over and as she was turning it over i noticed gas shouting out of the center of the carbin the picture it was leaking from the 2 holes in the center facing you.its a electronic dauljet carb.so basically it was flooding.i told her to stop pressing the gas she told me she wasnt. so i pulled the carb and got a rebuild kit. i took it apart cleaned it up and rebuild it but didn't replace the mixture control solenoid or the throttle position sensor. i did set the float to 11/32 as stated in the Manuel.i snugged all the horn bolts as stated didn't over tighten them as recommended. installed the carb today. it took awhile to get the gas going but it did the car started and wasnt running bad . but after a few minuets i noticed it was leaking gas around the mixture control solenoid. not sure why it is . the is a rubber seal that goes around the solenoid under the horn. this is my first time rebuilding a carb was told these are a nightmare
inkedrochester-quadrajet-17086004-carburetor-for_57_li-jpg.104124
. any suggestions why it would be leaking. thanks here is a picture of where it is leaking.
 
wonderboy24

wonderboy24

Royal Smart Person
Jul 10, 2012
1,167
651
113
Davenport, Iowa
#3
from what i can tell its leaking around the green thing in the picture. not the housing.here is a better picture.
inkedrochester-quadrajet-carburetor-chevrolet-replaces-17086004-cars-and_li-jpg.104127
 
Last edited:
jiho

jiho

G-Body Guru
Jul 26, 2013
543
145
28
#4
TURNA

TURNA

Geezer
Jul 24, 2009
6,981
9,189
113
Socialist NY
#5
If it wasn't leaking there and is leaking now.

It is because during the rebuild you disturbed it and broke the seal
 
MrSony

MrSony

Comic Book Super Hero
Nov 15, 2014
4,555
2,854
113
Des Moines, Iowa
#6
Thought this said crab guys.
 
techg8

techg8

Master Mechanic
Feb 29, 2012
414
167
43
#7
It is very easy to misalign that rubber seal that goes around the solenoid connector.

Be sure you're using the right one and that it seats fully in the top of the carburetor.
 
wonderboy24

wonderboy24

Royal Smart Person
Jul 10, 2012
1,167
651
113
Davenport, Iowa
#8
yeah i replaced the rubber seal that goes around it. looks like i have to take it back off the car and try again
 
pontiacgp

pontiacgp

Canadian Prime Minister
Mar 31, 2006
24,291
9,570
113
Kitchener, Ontario
#9
I'm no help with the E quadrajet but it's cool your mom drives an 86 Caprice.....and to keep with tradition we need pictures or it aint true...:cool:
 
Last edited:
BoostedJROD

BoostedJROD

Apprentice
Jan 9, 2019
61
89
18
#10
yeah i replaced the rubber seal that goes around it. looks like i have to take it back off the car and try again
Might have rolled the lip or maybe it got sliced putting it in. Rub a little petroleum jelly on it before installing
 

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot Mike's Montes P-S-T Southside Machine Performance UMI Performance

contact [email protected] for info on becoming a sponsor

copyright ©2018 Ripp Technical Services, All Rights Reserved.