Changed instrument panel lights, gauges not working

Call Her Bu

Apprentice
Dec 2, 2012
88
18
Arlington, TX
So I swapped out my gauge cluster bulbs for led lights and when I put it all back together, my gauges didn’t work except for the speedo. I made sure everything was back the way it was. So I think I did at least. Is there Something I should check for?

My signal lights in the gauge cluster don’t work either but they were like that before I changed bulbs. I bought a new flasher and still same result. Any other ideas?
 
  • Like
Reactions: g0thiac

g0thiac

Master Mechanic
Sep 6, 2020
302
43
So I swapped out my gauge cluster bulbs for led lights and when I put it all back together, my gauges didn’t work except for the speedo. I made sure everything was back the way it was. So I think I did at least. Is there Something I should check for?

My signal lights in the gauge cluster don’t work either but they were like that before I changed bulbs. I bought a new flasher and still same result. Any other ideas?
So what gauges don't work? If you installed LED's instead of regular bulbs, chances are you didn't wire something correctly, or install them with the polarity properly.

First, check to see if a fuse got f**ked. If that's good, use a multi meter and check around for voltage with the key off, and on.

My Pontiac didn't have working dash lights when I bought it, because the idiots who wired it before me did a LED dome light mod, so I added an LED strip, and wired it to a 12V source in the car.
 

Call Her Bu

Apprentice
Thread starter
Dec 2, 2012
88
18
Arlington, TX
So what gauges don't work? If you installed LED's instead of regular bulbs, chances are you didn't wire something correctly, or install them with the polarity properly.

First, check to see if a fuse got f**ked. If that's good, use a multi meter and check around for voltage with the key off, and on.

My Pontiac didn't have working dash lights when I bought it, because the idiots who wired it before me did a LED dome light mod, so I added an LED strip, and wired it to a 12V source in the car.
Tach, oil, fuel, temp and volts don’t work. They all did before. I’m going to disassemble and reconnect everything with the key forward.
 
  • Like
Reactions: g0thiac

Call Her Bu

Apprentice
Thread starter
Dec 2, 2012
88
18
Arlington, TX
Another thing, when I turn my lights on with the car off, they gauge lights work. As soon as I turn three key forward they turn off.
 

fly_25

Apprentice
Oct 20, 2020
74
18
Sometimes it's hard to get a good connection on the printed circuit board and the plug that plugs in to the dash. If it's not seated right then you'll get some dash problems. I've tried bending the tabs a bit on the plugs which helps a bit, I've also added some foam tape under the printed circuit board where is meets the plug to kinda "prop up" the connection and push it against the plug more
 
  • Like
Reactions: g0thiac

Call Her Bu

Apprentice
Thread starter
Dec 2, 2012
88
18
Arlington, TX
Sometimes it's hard to get a good connection on the printed circuit board and the plug that plugs in to the dash. If it's not seated right then you'll get some dash problems. I've tried bending the tabs a bit on the plugs which helps a bit, I've also added some foam tape under the printed circuit board where is meets the plug to kinda "prop up" the connection and push it against the plug more
That could be it. I’ll take it off and make sure it makes good connection. Thanks!
 
  • Like
Reactions: g0thiac

Call Her Bu

Apprentice
Thread starter
Dec 2, 2012
88
18
Arlington, TX
Ok so I put the regular bulbs back in and now they don’t turn on. Below is what happens with the car turned on.

Pic 1- gauges work when the headlight switch is off.
Pic 2- gauges go crazy or off when I turn on the headlight switch
Pic 3- when I turn the headlight switch while it’s on and turned all the way to the right, the halfway work?
 

Attachments

  • D61F2D53-73B9-4C02-B48A-39AF39608722.jpeg
    D61F2D53-73B9-4C02-B48A-39AF39608722.jpeg
    3.1 MB · Views: 39
  • 08868306-4FEA-4395-833A-1F5605D766B5.jpeg
    08868306-4FEA-4395-833A-1F5605D766B5.jpeg
    3 MB · Views: 35
  • 0DA673C3-BC70-4D18-9748-20F7264F9D15.jpeg
    0DA673C3-BC70-4D18-9748-20F7264F9D15.jpeg
    3 MB · Views: 39

Call Her Bu

Apprentice
Thread starter
Dec 2, 2012
88
18
Arlington, TX
With the key just turned forward, car not running.

Pic 1- headlight switch off
Pic 2- headlight switch on

HELP!!!!
 

Attachments

  • image.jpg
    image.jpg
    1.7 MB · Views: 34
  • image.jpg
    image.jpg
    1.7 MB · Views: 34

Similar threads

G-Body Performance Upgrades

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck ConsolesDixie Restoration DepotMike's MontesP-S-TSouthside Machine PerformanceUMI Performance

ContactAdmin@GBodyForum.comfor info on becoming a sponsor