Didn't know where to post this message

RobM

Apprentice
Nov 2, 2016
63
18
Ozone Park Kid
I have a 1987 Buick Regal Limited V6 231 na-(2barrel carb). When I apply the brake the rpm drop and when you release the brake the rpm goes back. The power booster has been changed and so has the check valve and the brake booster hose. I have checked for any vacuum leaks and not one to be found. I was thinking of trying a vacuum pump and see if that helps.
If anyone has an idea of what could be the cause, I'm all ears because I'm stumped.

Thanks, Rob
 
  • Like
Reactions: 1 user

liquidh8

Comic Book Super Hero
For troubleshooting: I would block off the vacuum lines coming from the carb/manifold to the booster. Fire it up, don't drive it, and see if it still does it. I understand the booster is new, but I've had them leak before right out of the box. If it doesn't do it, the booster is bad. If it still does, go to the next vacuum operated thing.

Mind you, interballs troubleshooting isn't the best idea.
 
  • Like
Reactions: 1 user

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot Mike's Montes UMI Performance

Contact Admin@GBodyForum.com for info on becoming a sponsor