1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Front upper control arm mount question

Discussion in 'Frame / Chassis / Suspension' started by Daca214, Dec 6, 2017.

  1. Daca214

    Daca214 Not-quite-so-new-guy

    Joined:
    Dec 1, 2017
    Messages:
    20
    Likes Received:
    12
    Trophy Points:
    3
    Location:
    Jupiter, FL
    hey guys. Hope somebody can help me out. I have a 84 buick regal that i pulled the hydraulics the PO had in there. He drilled out the shock mount. I have a welder friend who can fix it but i need to know exactly how the original looks with measurements. Does anyone have a picture looking down onto the top of the shock mount? As you can see in my pic i attached the hole is a little bigger now
     

    Attached Files:

  2. melloelky

    melloelky Apprentice

    Joined:
    Oct 22, 2017
    Messages:
    96
    Likes Received:
    83
    Trophy Points:
    18
    Location:
    mass
    bolt in your shock in from the bottom up and center the stud in the hole.go from there.
     
    • Agree Agree x 2
  3. fleming442

    fleming442 G-Body Guru

    Joined:
    Dec 26, 2013
    Messages:
    861
    Likes Received:
    575
    Trophy Points:
    93
    I agree; just weld it up and drill out the center. If that thing had hydros on it, it be looking for stress cracks.
     
    • Agree Agree x 1
  4. Daca214

    Daca214 Not-quite-so-new-guy

    Joined:
    Dec 1, 2017
    Messages:
    20
    Likes Received:
    12
    Trophy Points:
    3
    Location:
    Jupiter, FL
    i figured the hole was in the center, i just wanted to make sure since i have not seen one on a G body in its normal state. we didnt want it to be 1/2" off or more. (kinda new to this.)
    we checked for stress cracks and all looks good.

    thx
     
Loading...

Share This Page