1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fuse Keeps blowing for Instrument Gauges

Discussion in 'Electrical and Interior' started by BAMS909, Mar 18, 2017.

  1. BAMS909

    BAMS909 n00b

    Joined:
    Mar 18, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello Fellas. 1985 buick Regal Limited with 3.8 V6

    I have a question the 20a fuse In the fuse Block labeled Instrument keeps blowing the fuse which causes the Fuel Gauge not to work...

    1. The Fuse does not blow right away.
    2. I can start the car and Replace the Fuse and everything works as it should. But as soon as i drive the car around the block open Fuse Panel and Look the 20a its blown again, but if I take out and just let car Idol the fuse will not blow.

    Could there be a short in the sending unit that would cause this?
     
  2. Michael Farrell

    Michael Farrell Not-quite-so-new-guy

    Joined:
    Aug 4, 2016
    Messages:
    34
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Carleton Place, Ontario
    this ended up being a short on mine, was the wire running to my electric choke
     
  3. pontiacgp

    pontiacgp Rocket Powered Basset Hound

    Joined:
    Mar 31, 2006
    Messages:
    19,584
    Likes Received:
    1,943
    Trophy Points:
    113
    Location:
    Kitchener, Ontario
    have you unplugged the gas tank pink wire at the tank to see if the fuse still blows?
     
    • Like Like x 1
Loading...

Share This Page