Ls swap cranks, no fuel, no start

78elco

78elco

Not-quite-so-new-guy
Nov 14, 2017
18
4
3
#1
I have a drive by cable 5.3, factory harness striped down based on info from lt1swap. Vats and emissions cleared. Here’s where I’m at, I have spark. My in tank walbro fuel pump primes for two seconds, but then I don’t hear it running. If I jump the relay it will run constant but still no fuel at rails. I cracked open the return line on my corvette regulator and fuel comes out, but not on the engine side. Could the regulator not grounding or being bad out of the box cause it not to open and allow fuel to the rails.
 
8

81cutlass

Royal Smart Person
Feb 16, 2009
1,304
1,226
113
Western MN
#2
Do you have tach signal if you hook up hptuners and crank?
 
78elco

78elco

Not-quite-so-new-guy
Nov 14, 2017
18
4
3
#3
I don’t have hp tuners handy but I’m trying to get a friend out to the house to check it out. Would checking the signal just be to verify the pcm Is functioning or?
 
motorheadmike

motorheadmike

Comic Book Super Hero
Nov 18, 2009
2,865
3,066
113
Ottawa, Ontario Canada
#4
Hate to say it but you are pissing into the wind without a scanning/tuning suite like HP Tuners or EFI Live.
 
78elco

78elco

Not-quite-so-new-guy
Nov 14, 2017
18
4
3
#5
Hate to say it but you are pissing into the wind without a scanning/tuning suite like HP Tuners or EFI Live.
hopefully I’ll have it tomorrow. If the fuel pump is getting power and I’m not getting fuel to the rails, wouldn’t it either have to be the pump or regulator? My main question is can a bad corvette regulator not allow any fuel through.
 
motorheadmike

motorheadmike

Comic Book Super Hero
Nov 18, 2009
2,865
3,066
113
Ottawa, Ontario Canada
#7
Ground strap is to prevent static charge and fire.
 
78elco

78elco

Not-quite-so-new-guy
Nov 14, 2017
18
4
3
#8
I'm a little familiar with the corvette fuel filter/regulator, was going to use in in my build. I don't think the ground strap makes a difference. By chance do you have the return & feed lines reversed. Check this post:
http://67-72chevytrucks.com/vboard/showthread.php?t=699891
I think that article may be the solution. There is a lot of misinformation about how to hook up the regulator and I have the feed going to the center.
 
78elco

78elco

Not-quite-so-new-guy
Nov 14, 2017
18
4
3
#9
Got it running. I connected the fuel feed line and return to the regulator backwards based off some misinformation on the interwebs. Thanks Ostrich for that link.
 

Similar threads

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot Mike's Montes P-S-T Southside Machine Performance UMI Performance

contact [email protected] for info on becoming a sponsor