Speedometer cable

Rudy913

G-Body Guru
Feb 26, 2016
631
28
New Orleans
I notice my speedometer cable is leaking
And my speedometer In the cluster isn’t working either
Is the gear bad or the oring is causing it not to work ? Would one of these fix the problem ?
 

Attachments

  • 4881DD4C-E152-4E78-ABAE-ED608331F306.jpeg
    4881DD4C-E152-4E78-ABAE-ED608331F306.jpeg
    1 MB · Views: 6
  • 8444D691-5C9D-49F7-98D2-F09688162B00.jpeg
    8444D691-5C9D-49F7-98D2-F09688162B00.jpeg
    1.1 MB · Views: 6
  • C66D459B-B87A-4796-87F0-C761183A6D08.png
    C66D459B-B87A-4796-87F0-C761183A6D08.png
    3.8 MB · Views: 6
  • 19881766-7AAF-44AD-8FF7-59224CEE79BD.png
    19881766-7AAF-44AD-8FF7-59224CEE79BD.png
    1.7 MB · Views: 7
  • A4D9B761-45B4-4C41-9AFE-5B796ED527BC.png
    A4D9B761-45B4-4C41-9AFE-5B796ED527BC.png
    2.7 MB · Views: 6
  • 2ABAEB0B-156D-450F-B55A-88BBBCED863B.png
    2ABAEB0B-156D-450F-B55A-88BBBCED863B.png
    1.8 MB · Views: 8

JimmyCamino

Apprentice
Dec 15, 2020
63
18
Alexandria, VA
The cable housing looks like its been "worked". Probably need a new cable. Would be good if you had a spare cable end to attach to stick in there, jack up the car, turn the driveshaft and see if the cable moves.
 

-dw-

Not-quite-so-new-guy
Mar 15, 2021
19
13
The leak can be caused by a dried out housing oring or the plastic drive seal carved a groove into the plastic. Pull the housing and gear, check the gear teeth. Spin the cable with a power drill and watch the speedo if it show speed. If the car had factory cruise there should be transducer on the left fender, might be a problem with that.
 

Rudy913

G-Body Guru
Thread starter
Feb 26, 2016
631
28
New Orleans
The leak can be caused by a dried out housing oring or the plastic drive seal carved a groove into the plastic. Pull the housing and gear, check the gear teeth. Spin the cable with a power drill and watch the speedo if it show speed. If the car had factory cruise there should be transducer on the left fender, might be a problem with that.
It still have the cruise control but it doesn’t work
 

Similar threads

G-Body Performance Upgrades

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck ConsolesDixie Restoration DepotMike's MontesP-S-TSouthside Machine PerformanceUMI Performance

contactAdmin@GBodyForum.comfor info on becoming a sponsor