TH350 Detent Cable Replacement ?

Tynan918

Royal Smart Person
Thread starter
Aug 2, 2021
1,099
63
I'm having a issue with my downshifting and it being a little late or hesitant.. and it doesn't do it all the time but it does it a lot.

I checked the adjustment while I had the pan off doing a filter and fluid replacement it presses all the way in when I press the gas pedal all the way down, but I think there's a problem with the retracting when I let off the gas.

My cable is also a little rusted and bent... Which I think is causing the late or hesitant down shifting.
IMG_20220828_104019644.jpg


I shouldn't be able to hear the downshifting during deceleration right ? It should be so smooth I shouldn't hear it correct ?

I already have a new detent cable that I could install but if it there's nothing wrong with this one I'd rather not..
 
Last edited:

Tynan918

Royal Smart Person
Thread starter
Aug 2, 2021
1,099
63
I replaced the detent cable with the new one I bought and adjusted it correctly. Tight as a piano wire at wide open throttle and allows me to pull the throttle linkage back to wide open throttle without issue..
Screenshot_20220903-205207-988.png
Screenshot_20220903-205241-318.png


Problem solved...
 

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot Mike's Montes UMI Performance

Contact Admin@GBodyForum.com for info on becoming a sponsor