What Did You Do To Your G-Body Today? [2021]

old80cs

G-Body Guru
Jun 27, 2013
516
93
Massachusetts
Worked on my Cutlass for a while this afternoon, had to tend to an issue of my engine not sitting level (side to side) in the frame. It's been like that for a long time, no idea how I missed it as it stuck out like a sore thumb to me all summer while working on the body and paint with my friend. It's been at least 30 years since I stabbed the engine back in the frame after the repairs to body mounts and complete suspension rebuild. I had never put it back on the road, it's been in storage since then in my garage. After several attempts to pry bar it over, lifting the engine and prying it over etc nothing was working, still way off. I decided to try swapping the rubber mounts left to right to see if maybe that was the issue. I know the frame mounts weren't it as I never touched them when I did the frame repairs and such. Swapping the mounts did the trick, it sits level again. I must have removed them years ago when I replaced the oil pan while the car was apart and didn’t realize they had settled into there respective sides and crossed them up when I reinstalled them. Now that that is done I re-installed the starter and set my down pipes again to continue on with the new exhaust build. Not much progress lately but doing a little at a time as I'm (we're) able. No pictures now, but will grab some when there is something to look at.
 
Last edited:
  • Like
Reactions: 2 users

mclellan83

Comic Book Super Hero
Jun 27, 2017
3,263
113
Pgh, PA
Over the weekend I got the correct wire tapped for the head units, thanks again everyone. And of course with the upgraded unit it doesn't make as much difference since there is no side buttons on it
Season 3 Wall GIF by The Simpsons

So then i figured I would customize the units similar to the way I had the others, but for some reason the new unit won't let me log into Google or the Play Store so was trying to factory reset it. But it wouldn't take the normal pins for it, so I have to send a video of me putting in the pin to show what they say it should be won't work....
 
  • Sad
Reactions: 1 user

UC645

G-Body Guru
Apr 20, 2020
874
93
Kittanning, Pa
Currently altering the exhaust to sit about an inch higher, while putting in the option to change mufflers so I can (hopefully) avoid tickets.
No photos, so here’s the O2 bung I welded in
BB12F3A7-162F-4A0C-AD25-E3BC5319D129.jpeg
 
  • Like
Reactions: 3 users

Rodney Pickering

Apprentice
Mar 13, 2017
69
18
Got new gauges and rear bumper mounted on my 81 malibu.
 

Attachments

  • 186C10D6-DC74-4C8C-A90A-5486B92C15EC.jpeg
    186C10D6-DC74-4C8C-A90A-5486B92C15EC.jpeg
    3.2 MB · Views: 21
  • 1AD2E76A-E613-4EB7-9D43-BEEC1B9F0C52.jpeg
    1AD2E76A-E613-4EB7-9D43-BEEC1B9F0C52.jpeg
    3.5 MB · Views: 19
  • Like
Reactions: 10 users

79CutlassSupreme

Not-quite-so-new-guy
Sep 21, 2014
31
18
Wichita, KS
Well, it wasn't today... or even yesterday, but earlier this month I changed the gear oil in the rear of the '78 Cutlass. It was definitely way past due, but not too bad.
There seems to be a little excessive play on the axles, a very audible "Clunk" and visible movement between the button end of the axle and the pin. C-clips didn't look like they were too worn.
Is this movement normal, if so how much should there be and how much is too much? I measured the gap but don't recall what the measurements were... (wrote them down but lost the paper I wrote them on.) Anyway, I needed it back together and off the jack stands so I sealed it and filled it back up to worry about another time.
. IMG_2697.JPG IMG_2685.JPG IMG_2684.JPG
 
  • Like
Reactions: 1 user

Supercharged111

Comic Book Super Hero
Oct 25, 2019
3,941
113
Colorado Springs, CO
Well, it wasn't today... or even yesterday, but earlier this month I changed the gear oil in the rear of the '78 Cutlass. It was definitely way past due, but not too bad.
There seems to be a little excessive play on the axles, a very audible "Clunk" and visible movement between the button end of the axle and the pin. C-clips didn't look like they were too worn.
Is this movement normal, if so how much should there be and how much is too much? I measured the gap but don't recall what the measurements were... (wrote them down but lost the paper I wrote them on.) Anyway, I needed it back together and off the jack stands so I sealed it and filled it back up to worry about another time.
. View attachment 211960 View attachment 211962 View attachment 211961

I lost the numbers from my Camaro, but I want to say one side had about .020" and the other was definitely at or right around .040". I rosette welded the axle shafts to get about .010" per side. No idea what spec would be.
 
  • Like
Reactions: 1 user

MrSony

Geezer
Nov 15, 2014
6,488
113
Des Moines, Iowa
Replaced the headlights with 4 new ones for the first time. Always just replaced one at a time. I know ive only ever replaced 3 of them, and the driver's highbeam sad USA on it, so that one may be original.
Added a ground from the engine to the frame, cleaned up some others. These are all the grounds my car has in the engine compartment. I've noticed that just with the act of turning on the blower motor my volt gauge temporarily drops from 13.5-14.5 to 12 or less volts but then shoots right back up. These draw that much power?

First pic: passenger headlight ground and battery neg offshoot to fender
Second pic: an extra ground i added from the blower motor to the fender, other wires to fender are antenna wires. idk how but it made the antenna pick up signal better lol
Third pic: driver's side headlight ground and fan grounds. there's two because the extra wire would normally be grounded through a temp switch
Fourth pic: from left to right, hvac and heater core ground, strap from bellhousing to firewall, cruise ground
Fifth pic: engine to frame ground i added, and the negative battery cable mounts to the alternator bracket with a through bolt into the head, i also shortened that cable so it wasn't like 6" longer than it needed to be
grounds5.jpg
grounds4.jpg
grounds3.jpg
grounds2.jpg
grounds1.jpg
 
  • Like
Reactions: 2 users

mclellan83

Comic Book Super Hero
Jun 27, 2017
3,263
113
Pgh, PA
Finally got it to place nice after some tech help, for some reason they updated it to the same software my bottom unit is running. Now some minor tinkering to get it completely the way I want but so much better. Now that pesky distributor one of these days hahaha

20221130_210245.jpg
 
  • Like
Reactions: 3 users

Texas82GP

Just-a-worm
Apr 3, 2015
7,729
113
Spring, Texas
  • Agree
  • Like
Reactions: 1 users

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot UMI Performance

Contact Admin@GBodyForum.com for info on becoming a sponsor