GBodyForum Supporting Vendor

Ignition / Key Issue

jad99125
n00b
 
Posts: 18
Joined: Sat Jul 28, 2012 9:58 am

Ignition / Key Issue

Postby jad99125 on Fri Jun 21, 2013 10:30 am

Hey guys, I am having a problem with my key igntion. I read alot fo the posts here but doesn't seem to help and it is just alot of back and forth on the topic. Here is the problem. I pulled into a parking lot and shut the car off. When I got back in and tried to start it it would only go to the ON position and only back to the OFF position. No Start or Lock position. The radio and lights go on. I read the manual and thought it was a nuetral safety switch issue but I can not find one and the manual was not too detailed. Just said it is connected with 2 bolts on the side of the tranny. I couldn't find one. So I ruled that out. Right now I have the column dropped to get to the ignition swith on top of the column under the dash. Bolts are oout but I can not take it off because the "detent?" lever is holding on. Any suggestions on how to get it out as I have the column dropped but not out. Am I on the right path? I tried all the simple stuff like turning the wheels from lock to lock and trying it in nuetral. Nothing worked. I got it to start a couple times by not trying anything but turning the key. I turned it on and off about 6 times without moving the car or turning the wheels and on the 7th time it happened again. Hoping it is the ignition module but not 100% sure. If I can get it out I will be able to test it (just continuity right?) There is no special range or resistance it needs from what I can find. Please help as I have beautiful weather and 3 days wrenching without a positive solution. So now my car is sitting in front of my garage with no steering wheel and the T-tops on with beautiful 80deg weather :evil: I shed a tear everytime I look at it. Thanks everyone!!!

67rstbkt
Moderator
 
Posts: 571
Joined: Thu Sep 30, 2010 9:46 am
Location: Reno, Nevada

Re: Ignition / Key Issue

Postby 67rstbkt on Fri Jun 21, 2013 10:42 am

There is a rod that travels through the column and moves the positions on the electrical portion of the ignition switch located further down on the colum. Make sure that is moving to all positions, you could have a bind somewhere. Since you're on a G-body forum, I'm assuming you are working an a G-body?
The neutral safety should be mechanical - moving the shifter on the column should move some pieces down the line as well. Make sure these parts are moving through the range (Drive, Neutral, Reverse, etc..)
It sounds to me like the problem is somewhere in the parts I described. If the key is not physically moving, then something is jammed. Could also be the ignition cylinder - this is a pretty common failure, especially as these cars get older.

jman13
n00b
 
Posts: 1
Joined: Mon Jun 24, 2013 8:16 am

Re: Ignition / Key Issue

Postby jman13 on Mon Jun 24, 2013 8:21 am

Did you find out what was causing the problem? Mine is doing the same thing. I'm hoping its the ignition switch. Please let me know if and how you fixed it. Thanks

jad99125
n00b
 
Posts: 18
Joined: Sat Jul 28, 2012 9:58 am

Re: Ignition / Key Issue

Postby jad99125 on Sat Jun 29, 2013 10:07 pm

Ya, it is a gbody. 1984 Buick t-type wh1 with a center console (so no column shifter). I still haven't figured it out. I'm having a hard time figuring it out. I can not move the rod through the whole range but can't find a bind. I also removed the key cylinder and that seems to turn fine. I'm trying to get the column out but it's not that easy or straight forward. :cry: (missing my buick)

User avatar
Blake442
Royal Smart Person
 
Posts: 6568
Joined: Tue Apr 24, 2007 6:46 pm
Location: Minneapolis

Re: Ignition / Key Issue

Postby Blake442 on Wed Jul 03, 2013 10:09 am

Even floor shift models have the rod going from the column to the trans.
When you shift, the column will rotate like there is a phantom shifter attached to it.

As the bushings wear, it can lead to the column not moving fully into the park position. Grab it with your hand and see it it rotates further.
'85 Oldsmobile 442--Olds 455-TH400
'83 Oldsmobile Cutlass Cruiser--Chevy 350-TH350
Past G's--'81 Regal, '84 El Camino, '79 Cutlass Supreme, '87 Cutlass Salon,
'81 Monte Carlo, '81 El Camino, '79 Malibu Wagon, '81 Century Estate Wagon

Free Shipping on Orders Over $75!
jad99125
n00b
 
Posts: 18
Joined: Sat Jul 28, 2012 9:58 am

Re: Ignition / Key Issue

Postby jad99125 on Wed Jul 03, 2013 11:47 am

Update:
I took most of the column apart and removed the gear on the opposite side of the key ignition. The ignition still won't turn. Is there a cam or did something break? And I still can not remove the column. I undid the top bolt of the steering linkage and the E-clip around the bearing. What am I missing?

Thanks alot guys


Free Shipping on Orders Over $75!

Return to Buick Regal / T-Type / Grand National / GNX

Who is online

Users browsing this forum: Exabot [Bot]