EL CAMINO 1987 in electrical hell!

vpmac

vpmac

Not-quite-so-new-guy
May 14, 2017
19
1
3
Fayetteville Ga.
#1
All I wanted to do was install Autometer gauges in my El Camino. Pulled the dash cluster found the wires for each gauge and dash lights after some help here on the forum. The numbered diagram was a great help. Many thanks. So with the cluster out I now have no power to the accessory side of the ignition. No radio, no heater blower. I checked all fuses, and the fuse links down by the starter. They are all good. Is there a connection between the gauge cluster connector and the ignition that I don't know about. There is a wire on the diagram that says Ing/ acc coming from the gauge cluster, could this need to be connected to something? Could a wire from the gauge cluster go back to the ignition switch? Does anyone know a good auto electrical guy that does house calls in the Atlanta area?

Thanks

Mac
 
vpmac

vpmac

Not-quite-so-new-guy
May 14, 2017
19
1
3
Fayetteville Ga.
#2
I found it!! Believe it or not, the ground wire to the blower fan was not making good contact. I did not know that ground also is the ground for you wipers. Duh! Still figuring out why the radio is not getting power. Peogress..

Mac
 
Daca214

Daca214

Master Mechanic
Dec 1, 2017
253
178
43
Jupiter, FL
#3
Thats good info to know. Thanks for the update.
 

Similar threads

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot Mike's Montes P-S-T Southside Machine Performance UMI Performance

contact [email protected] for info on becoming a sponsor