Loose brown connector near fuse box

brrian

Apprentice
Jul 7, 2022
80
18
Pittsburgh, PA
This odd-looking connector is hanging loose in front of my fuse box. It's brown with a light and (I think) dark gray wire. What is this?

I have no chimes, buzzers, etc. - no warning sounds, and the seatbelt light is always on, whether the seatbelts are connected or not. I'm starting with the chime box but found this & thought to ask here first in case it's related.

1659645993641.png
 

brrian

Apprentice
Thread starter
Jul 7, 2022
80
18
Pittsburgh, PA
...did some research & I think it might be the rear defroster connection to the fuse box. According to the service manual it should go in the location shown below. It looks like the right shape but it won't fit. there's a thin brown strip / ridge on the connector (visible in the above pic, on the left side) & that seems to be what's preventing it.

Is this the defroster connection, and is this the right fuse location?

1659648610148.png
 

pagrunt

Geezer
Sep 14, 2014
7,866
113
Elderton, Pa
...did some research & I think it might be the rear defroster connection to the fuse box. According to the service manual it should go in the location shown below. It looks like the right shape but it won't fit. there's a thin brown strip / ridge on the connector (visible in the above pic, on the left side) & that seems to be what's preventing it.

Is this the defroster connection, and is this the right fuse location?

View attachment 204036
Those plug into specific ports, see if it'll plug into the LPS port. Bet it'll be for the lights on buzzer.
 
  • Like
Reactions: 1 user

oldsmobile joe

Royal Smart Person
Nov 12, 2015
2,029
113
mpls
Those are keyed for a reason. If it don't fit, try a different location. I would try the "LPS" location. The wire that is piggybacking is gray, and gray wires in that area are usually for lights.
 
  • Like
Reactions: 1 user

brrian

Apprentice
Thread starter
Jul 7, 2022
80
18
Pittsburgh, PA
Those plug into specific ports, see if it'll plug into the LPS port. Bet it'll be for the lights on buzzer.
Winner! It fit into the LPS port, and my lights on chime now works. Quiet, but works. Thanks!
 
  • Like
Reactions: 1 user

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot Mike's Montes P-S-T Southside Machine Performance UMI Performance

Contact Admin@GBodyForum.com for info on becoming a sponsor