1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No Power to AC Compressor on 85 442

Discussion in 'General Discussion' started by 85Cutty442, Feb 11, 2018.

  1. Ribbedroof

    Ribbedroof Royal Smart Person

    Joined:
    Jan 4, 2009
    Messages:
    1,770
    Likes Received:
    495
    Trophy Points:
    83
    Location:
    107 miles from Nowhere, OK
    Standard Motor products HS316 (replaces GM#16001570)

    [​IMG]

    You're looking to replace the big orange switch with the white retainer in the center between the vacuum switch and the fan speed switch
     
    #21 Ribbedroof, Feb 12, 2018
    Last edited: Feb 12, 2018
    • Like Like x 1
  2. Ribbedroof

    Ribbedroof Royal Smart Person

    Joined:
    Jan 4, 2009
    Messages:
    1,770
    Likes Received:
    495
    Trophy Points:
    83
    Location:
    107 miles from Nowhere, OK
    The more I think about it, the more I wonder if yours came apart as well....that white plastic pin is 32+ years old and not very stout to begin with
     
    • Like Like x 1
  3. 85Cutty442

    85Cutty442 Not-quite-so-new-guy

    Joined:
    May 1, 2016
    Messages:
    19
    Likes Received:
    1
    Trophy Points:
    3
    Wow
    Thank you very much!!
    I almost went out looking for the wrong switch.
    Thank you

    Heading out now to see if my little town has this on the shelf by chance
     
    • Like Like x 1
  4. 85Cutty442

    85Cutty442 Not-quite-so-new-guy

    Joined:
    May 1, 2016
    Messages:
    19
    Likes Received:
    1
    Trophy Points:
    3
    Ok
    I replaced switch and same deal.
    So I took radio out, glove compartment, and under dash panel
    So I have a clear sight of the wires.

    I’m getting power through a brown wire that plugs into the switch.
    I have power in and power out.

    The green wire in the plug that plugs into the switch is not the same wire at the light pressure switch in the engine bay.

    Switch wire is green w/black stripe.
    Solid green wire at the low pressure switch.

    That green wire travels to under the dash where it’s plugged into some kind of plug.
    No power going into it.

    I’ve taken pics to help you see what I see.

    I don’t get it
     
  5. 85Cutty442

    85Cutty442 Not-quite-so-new-guy

    Joined:
    May 1, 2016
    Messages:
    19
    Likes Received:
    1
    Trophy Points:
    3
    Here’s the plugs I’m referring too
     

    Attached Files:

  6. Ribbedroof

    Ribbedroof Royal Smart Person

    Joined:
    Jan 4, 2009
    Messages:
    1,770
    Likes Received:
    495
    Trophy Points:
    83
    Location:
    107 miles from Nowhere, OK
Loading...
Similar Threads - Power Compressor 442 Forum Date
2018 Power Tour East coast!!! General Discussion Dec 22, 2017
Year One Powercrate 350?? General Discussion Oct 4, 2017
86 monte ss starts but no power General Discussion Sep 28, 2017
Power brake question General Discussion Aug 16, 2017
1973 Trans Am with an ASC Power Sunroof General Discussion Aug 2, 2017

Share This Page