CCC Elimination on 83 OLDS 98 Coupe 307

TURNA

TURNA

Geezer
Jul 24, 2009
8,432
113
Socialist NY
Look at the gas pedal there may be a switch on it that turns off the AC during full acceleration.

Maybe that has something to do with it



 
O

OLDSMOBILE307

Not-quite-so-new-guy
Jun 14, 2018
10
3
Finally drove it Sunday. Did pretty good. Engine runs great. Still a dog unfortunately. Was hoping it would have a few more Hp, but nothing really noticeable. I may try richening the APT screw, but I have a feeling this is about all the power this engine has. Along with the highway gearing in the rear end, it's just a slow boat.

Also - The A/C turned on and worked fine. Even with the idle increase solenoid removed, engine still kept running. I may want to increase the idle speed slightly (currently about 8-900 in park). May not want to turn it on sitting in traffic at a stop light, etc..

The TCI trans lockup solenoid was not working correctly. TCI says I just need to adjust it clockwise. It was slipping badly if you stepping on the gas in 4th.Hopefully that will be easy to resolve.
 
1984_Delta88

1984_Delta88

Not-quite-so-new-guy
Apr 12, 2019
7
3
I do not want to steal this thread, but I think it kind of fits... even if it is a D88. Still with the 307 engine.

Some might lough, but I need some help to get the smog pump system back running. I imported my Delta 88 from the states. Here in Germany it will most likely be impossible to get it street legal with not all the systems working correct as we do have exhaust emission testing.

There are two items I need to work on. First: (picture attached)

The previous owner was quite creative (or should I say lazy :sneaky:). He cut and bent the metal tubing that comes out of the headers. I found the tubing on rockauto or ebay. With the search in this forum I found some pictures where it seems as if there was just a check valve and a hose that is routed somewhere. Can I get this valve or whatever it is as a spare part and just attach it with some hose? This would mean the metal tube could be fixed? Or should I get a new one?





Second (picture attached):

I guess this is the air pump / switch. 2 hoses are not connect. One is…”plugged” :unsure::X3:. Could anybody briefly explain how this thing is supposed to work and where those hoses are supposed to go?
Does somebody have a correct tubing diagram? The one in my repair manual does not really help much with this.
 

Attachments

TURNA

TURNA

Geezer
Jul 24, 2009
8,432
113
Socialist NY
I think I still have my air tubes (the metal ones) If I do u can have them
 
MrSony

MrSony

Comic Book Super Hero
Nov 15, 2014
4,869
113
Des Moines, Iowa
The cel will stay lit forever until it burns out. Pull the bulb... Or get creative and figure out a way to make it come on via oil pressure or something.
 
Wageslave

Wageslave

G-Body Guru
Jan 25, 2017
878
93
You'll have to pull the bulb for the check engine light.
I think there is a Black/White wire in that ECM to dash harness connector that can be grounded to turn that light off. That is what I had to do when I yanked my harness.
 
1984_Delta88

1984_Delta88

Not-quite-so-new-guy
Apr 12, 2019
7
3
Oh Dear... totally forgot this thread. Sorry guys and thanks for the answers. But I guess you got me wrong. I want to reinstall the SMOG system! Got myself new pipes. But I still have no clou where those connections in picture 2 in my previous post are supposed to go? One on each pipe (with a checkvalve?)?
 
Clone TIE Pilot

Clone TIE Pilot

Royal Smart Person
Aug 14, 2011
1,987
113
Galaxy far far away
I do not want to steal this thread, but I think it kind of fits... even if it is a D88. Still with the 307 engine.

Some might lough, but I need some help to get the smog pump system back running. I imported my Delta 88 from the states. Here in Germany it will most likely be impossible to get it street legal with not all the systems working correct as we do have exhaust emission testing.

There are two items I need to work on. First: (picture attached)

The previous owner was quite creative (or should I say lazy :sneaky:). He cut and bent the metal tubing that comes out of the headers. I found the tubing on rockauto or ebay. With the search in this forum I found some pictures where it seems as if there was just a check valve and a hose that is routed somewhere. Can I get this valve or whatever it is as a spare part and just attach it with some hose? This would mean the metal tube could be fixed? Or should I get a new one?





Second (picture attached):

I guess this is the air pump / switch. 2 hoses are not connect. One is…”plugged” :unsure::X3:. Could anybody briefly explain how this thing is supposed to work and where those hoses are supposed to go?
Does somebody have a correct tubing diagram? The one in my repair manual does not really help much with this.
Upper right angle barb is for the hose that goes over to the exhaust manifold on the side of the engine. Lower hose with the spark plug in it is supposed to hook up to a metal pipe that is supposed to be attached to the cat converter.
 
Last edited:
1984_Delta88

1984_Delta88

Not-quite-so-new-guy
Apr 12, 2019
7
3
Thanks! Found the connection at the catalytic converter. Looks almost factory sealed ;-) Gonna get myself some proper hoses to get it all connected again.(y)(y)(y):)
 

Attachments

Please support GBodyForum Sponsors

Classic Truck ConsolesDixie Restoration DepotMike's MontesP-S-TSouthside Machine PerformanceUMI Performance

contact[email protected]for info on becoming a sponsor