Dash wiring.

R

robert garringer

Not-quite-so-new-guy
May 9, 2018
13
3
3
bradenton,florida
#1
i have a 87 monte ss. and i am having trouble finding out why i cant get the dash lights to work . The ac/heat control lights work fine it looks like the gray wire that plugs into the gauge cluster is the one that powers the lights.and it has power when the switch is on and pluged in it is hot but no lights every thing else in the dash works fine. any help would be great,bob.
 
M

mikester

G-Body Guru
Mar 10, 2010
865
562
93
Small town NY
#2
Are any of them working ? Directional lights ?
 
R

robert garringer

Not-quite-so-new-guy
May 9, 2018
13
3
3
bradenton,florida
#3
Yes all the turn signals work but some body has replaced the the sockets on the front running and turns.Which i had to fix because some jack ass just peeled the wire back and twisted the wires together with electrical tape. Plus all the lights are working correctly the only lights that are not working are all the lights inside the dash.
 
Last edited:
M

mikester

G-Body Guru
Mar 10, 2010
865
562
93
Small town NY
#5
Yes all the turn signals work but some body has replaced the the sockets on the front running and turns.Which i had to fix because some jack ass just peeled the wire back and twisted the wires together with electrical tape. Plus all the lights are working correctly the only lights that are not working are all the lights inside the dash.
I didnt mean the lights, I meant the directional indicator lights in the dash. Nothing in the dash works ? I would check all the ground wires. I just had my dash out recently. Not sure what grounds are for the dash lights but there was one under the column and one on each side of the dash where the bolts are that hold the dash in.
I had some of the lights go out but not all. I had replaced the printed circuit and it turned out that some of the sockets were the issue. All new bulbs. I bench tested the sockets, replaced the ones that didnt work. Now I have all of them lit. I hate electrical issues.
 
R

robert garringer

Not-quite-so-new-guy
May 9, 2018
13
3
3
bradenton,florida
#6
I didnt mean the lights, I meant the directional indicator lights in the dash. Nothing in the dash works ? I would check all the ground wires. I just had my dash out recently. Not sure what grounds are for the dash lights but there was one under the column and one on each side of the dash where the bolts are that hold the dash in.
I had some of the lights go out but not all. I had replaced the printed circuit and it turned out that some of the sockets were the issue. All new bulbs. I bench tested the sockets, replaced the ones that didnt work. Now I have all of them lit. I hate electrical issues.
yes i do not care for electical work either. Yes every thing in the dash works except for all the lights. the ash tray and the ac/heater lights work.the dimmer works the turns work.i thought it was the switch t first but ruled that out pretty quick.On the bottum of the circuit board from the right side going to the right five slots including the third which is empty thats the light wire and its gray i believe. Is that correct or is it another one?
 
fleming442

fleming442

Comic Book Super Hero
Dec 26, 2013
4,115
2,046
113
#7
yes i do not care for electical work either. Yes every thing in the dash works except for all the lights. the ash tray and the ac/heater lights work.the dimmer works the turns work.i thought it was the switch t first but ruled that out pretty quick.On the bottum of the circuit board from the right side going to the right five slots including the third which is empty thats the light wire and its gray i believe. Is that correct or is it another one?
If that is true, you just found your problem; I'd say. Buuuuut......,
it looks like the gray wire that plugs into the gauge cluster is the one that powers the lights.and it has power when the switch is on and pluged in it is hot but no lights every thing else in the dash works fine.
Is it there and has power or not?
 
R

robert garringer

Not-quite-so-new-guy
May 9, 2018
13
3
3
bradenton,florida
#8
If that is true, you just found your problem; I'd say. Buuuuut......,

Is it there and has power or not?
yes it has power. now that is with the head light switch in the on position.
 
M

mikester

G-Body Guru
Mar 10, 2010
865
562
93
Small town NY
#9
Pick the minds of everyone on this forum. The issue have seems far worse than the one I had.
 
R

robert garringer

Not-quite-so-new-guy
May 9, 2018
13
3
3
bradenton,florida
#10
Pick the minds of everyone on this forum. The issue have seems far worse than the one I had.
im new so i dont know how to get to every one out there.So any help would be great. thanks for your help,bob.
 

Similar threads

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot Mike's Montes P-S-T Southside Machine Performance UMI Performance

contact [email protected] for info on becoming a sponsor