starter clicking , no crank

michael_boomin

Not-quite-so-new-guy
Dec 29, 2020
12
3
trying to start 78 el camino (350) . battery is reading 12.4 at battery and when read at starter. the problem is when i go to start, the starter clicks repeatedly and never actually cranks. while connected to float charger the battery some times reads at high as 14.5, gets momentary attempt at cranking then continues to click. starter was replaced a year ago after the same issue and worked for about a year but with minimal use. after starter was changed ,a few wires to starter (fuseable link?) burned on headers and stopped working after i repaired them (worked while burning on headers) . looking for help on fixing this issue. i don’t believe it is the battery that needs replaced but seems like it may be wiring issue. all advice is appreciated .
 

ck80

Geezer
Feb 18, 2014
5,035
113
trying to start 78 el camino (350) . battery is reading 12.4 at battery and when read at starter. the problem is when i go to start, the starter clicks repeatedly and never actually cranks. while connected to float charger the battery some times reads at high as 14.5, gets momentary attempt at cranking then continues to click. starter was replaced a year ago after the same issue and worked for about a year but with minimal use. after starter was changed ,a few wires to starter (fuseable link?) burned on headers and stopped working after i repaired them (worked while burning on headers) . looking for help on fixing this issue. i don’t believe it is the battery that needs replaced but seems like it may be wiring issue. all advice is appreciated .
Initially speaking, your battery doesn't seem to have the juice to start. Try some jumper cables, not just the charger and see if you start. Likelynwill.

That accomplished, check the grounds well for cleanliness and contact tightness. Your step after that would be hunting parasitic drain, maybe starting by poking around thebaltern a tornwith a tester
 

dmac35242

Not-quite-so-new-guy
Dec 23, 2021
25
13
Birmingham, AL
I'd put a jump on it.
If that doesn't help, I'd remove and clean all associated grounds.
Still no bueno, remove starter and have tested at parts store.
Good news is you've got the click so you can feel good about the switch wiring.
 

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck Consoles Dixie Restoration Depot UMI Performance

Contact [email protected] for info on becoming a sponsor