Changed instrument panel lights, gauges not working

fly_25

Apprentice
Oct 20, 2020
78
18
Evil electrical gremlins. Try inspecting the wiring going to the dash plug and the light switch and look for any exposed wires or potential shorts/damages. Take a look at the printed circuit board as well, some copper could be misplaced and touching another circuits. These are just guesses. Just a good overall inspection to start with. I also think there is a ground wire under the dash that you could check out
 
  • Like
Reactions: g0thiac

Call Her Bu

Apprentice
Thread starter
Dec 2, 2012
88
18
Arlington, TX
Evil electrical gremlins. Try inspecting the wiring going to the dash plug and the light switch and look for any exposed wires or potential shorts/damages. Take a look at the printed circuit board as well, some copper could be misplaced and touching another circuits. These are just guesses. Just a good overall inspection to start with. I also think there is a ground wire under the dash that you could check out
Ok I’ll look at all that this afternoon. Thanks. 😓
 

g0thiac

Master Mechanic
Sep 6, 2020
308
43
With the key just turned forward, car not running.

Pic 1- headlight switch off
Pic 2- headlight switch on

HELP!!!!
So I'm gonna say this is a loose ground, or a hot to ground condition. You sure the fuses are good also right?

If your fuel gauge is stuck below E, it's a ground issue. If it's stuck past full like mine was, it's not getting the correct DC 12 voltage.
 

Call Her Bu

Apprentice
Thread starter
Dec 2, 2012
88
18
Arlington, TX
So I'm gonna say this is a loose ground, or a hot to ground condition. You sure the fuses are good also right?

If your fuel gauge is stuck below E, it's a ground issue. If it's stuck past full like mine was, it's not getting the correct DC 12 voltage.
Yes the fuses are all good. All I did was change bulbs to led then back to regular. I’ll check ground and connections again. Thanks for your help.
 
  • Like
Reactions: g0thiac

abbey castro

Master Mechanic
Oct 31, 2015
287
63
Harker Hts TX
Just did mine to LEDs. Had to turn some of them around in the sockets since mine have polarity. That was hassle in the remove and install with a needle nose plier. The printed circuit for the lights has nothing to with the gages. The center cluster has pegs that fit into the back of the 4 gages. Same for the tach. Are those mating together correctly. If you removed the harness at the cluster and then reinstalled it is hard to get a good alignment. I did that once and it took me hours of trying to align the tape harness to the cluster. Good luck!
 

Similar threads

G-Body Performance Upgrades

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck ConsolesDixie Restoration DepotMike's MontesP-S-TSouthside Machine PerformanceUMI Performance

ContactAdmin@GBodyForum.comfor info on becoming a sponsor