Do I get a membership card now?

Turbo Zach

Turbo Zach

Royal Smart Person
Sep 8, 2015
1,640
113
50130
I would trade for some stock Blazer spindles if I new they would be a true two inch drop? I have G Body two inch drop spindles now and they dropped the car three inches witch was too much for my liking.
 
8

81cutlass

Royal Smart Person
Feb 16, 2009
1,854
113
Western MN
Threw the bearings and dust shields on the stock spindles I had. Cleaned the spindles up since they were pretty dirty, shot some paint, and installed them. Need to bleed brakes tomorrow.

1561432687271.png

1561432694622.png
 
8

81cutlass

Royal Smart Person
Feb 16, 2009
1,854
113
Western MN
Did you make it to the car show?
I kinda did but nothing I own is eligible. I just hung on the street outside the show for a hour or so and watched people act like fools and do burnouts. It's for 64 and earlier stuff only, no mustangs.


In other news, I finished the front breaks up tonight. Ended up having the wrong size flare nuts (1/4 instead of 3/16 that I didn't even notice) so I had to cut the nuts off, put the right size on and reflare. Had to redo the drivers side since it kept leaking even though the flare was perfect.

Took it for a quick spin and the brakes are way better. Still have a little air in them since I only bled the fronts but it stops pretty good now. Brakes have always been awful on this car so the fact its functional now is nice :)

Needs an alignment though, it drives straight but turns left real easy and turns right harder, set up like a dirt car! Lol....

I got the AC recieiver drier on and the new O-rings, i need to get AC PAG oil in and vac the system tomorrow, see if it holds vac and then fill Friday.
 
8

81cutlass

Royal Smart Person
Feb 16, 2009
1,854
113
Western MN
Well it's going to be 90+ tomorrow so I decided to get the AC working.

Good news, the AC is working
Bad news, car doesn't start again. POS.

Put the new seal kit in, put some new oil in, vacc'ed the system, filled it up and cooled great!

Had an issue getting the compressor to turn on initially, turns out I don't have a brake switch wired up (apparently when you hit the brakes the AC turns off???) and the relay gets power from there, I didn't have that wire so I just used an aligator clip to the fuel pump power wire which I pull directly off the alternator lug.

Shut the car on and off half a dozen times, got the cooling temp down to high 40F, I was stoked.

Shut car off, ran a wire to the auxiliary fuse panel from the passenger side AC cutoff relay, wired it up, car wouldn't start. Probed the harness, didn't see anything obvious, literally didn't touch anything but the 1 AC cutoff wire and spliced off my fuse panel for power, car started and shut off multiple times between there, no issues. Not it won't start.

Again, this car is cursed or I am clueless, I lean more toward the 1st.
1561693916925.png


Oh and the EPA mandated special check valve AC bottles now, I am borrowing Dad's AC kit. I hadn't bought AC cans for about a year and saw the new ones all take a special "new" hose. Apparently the aftermarket already figured that out and you just pierce the side of the can with a handle thing. Talk about a fast response to a problem I didn't know existed.
1561694035820.png
 
TURNA

TURNA

Geezer
Jul 24, 2009
8,416
113
Socialist NY
Remove the wire you installed, does it start?

When you messed with the fuel pump power did the fuse blow?
 
  • Like
Reactions: Texas82GP
TURNA

TURNA

Geezer
Jul 24, 2009
8,416
113
Socialist NY
Usually its a switch on the gas pedal

When you floor it it cuts off the AC for full POWER!!!!!!!!!!!
 
  • Agree
Reactions: fleming442
8

81cutlass

Royal Smart Person
Feb 16, 2009
1,854
113
Western MN
I can hear the fuel pump running so I assume I didn't blow the fuse
I removed the additional wire I put in, didn't start.
Even checked all the fuses under the dash and the new ones I put under the hood

Brake switch power to the AC cutout relay didn't make much sense to me either but thats what the diagram showed. I had no voltage to that pink/black wire and when I put voltage to it the AC worked.
1561721312400.png
 
  • Like
Reactions: motorheadmike

Please support GBodyForum Sponsors

Classic Truck ConsolesDixie Restoration DepotMike's MontesP-S-TSouthside Machine PerformanceUMI Performance

contact[email protected]for info on becoming a sponsor