What did you do to your G-Body today? [2019]

melloelky

melloelky

Royal Smart Person
Oct 22, 2017
1,323
113
mass
[QUOTE="Injectedcutty
I'm brainstorming for trans cooler mount ideas. The new cooler is too heavy for me to comfortably mount it to the radiator. i don't know if this helps you @ all but the holes were already in the support to accept these brackets i made.maybe you fit the cooler in front of the condenser.
P1010082.JPG
 
Injectedcutty

Injectedcutty

Comic Book Super Hero
Nov 24, 2014
3,877
113
Louisville, KY
[QUOTE="Injectedcutty
I'm brainstorming for trans cooler mount ideas. The new cooler is too heavy for me to comfortably mount it to the radiator. i don't know if this helps you @ all but the holes were already in the support to accept these brackets i made.maybe you fit the cooler in front of the condenser.View attachment 108650
Haha, same cooler! Did you paint the front of your rad black, or is that the lighting?
My Cutlass doesn't have holes in the support, but it can with a drill bit lol.
Issue I have is the cross braces, and I don't have A/C so no condenser to worry about.
 
RG383Hurst

RG383Hurst

Not-quite-so-new-guy
Mar 7, 2015
48
33
thats nice, i like it. i have had a similar idea of doing this with a FI tank from a 95 caprice. what or where did get the upper tank stops? did you just cut out and move the originals or did you graft in ones for a camaro?
Thanks. I used 2 driver sides from a cutlass. I moved my original and cut another driver side off of a parts car. Used the original lower tanks straps as well, just rebent in the configuration I needed. Also had to heat and dolly the trunk floor so the filler tube would fit. I like that it’s 1” shallower than the original and it holds 20 gallons.
 

Attachments

MrSony

MrSony

Comic Book Super Hero
Nov 15, 2014
4,800
113
Des Moines, Iowa
Changed spark plugs from my R45tsx (.060 gap) to the R45TS (.045 gap). No noticable difference. My engine has always had a simmy to it at idle, I was hoping that would cure it. It's either a balance issue (but it goes away even at 1000rpm, only does it at idle speed), or it's a combination of the derpy $11 v6 motor mounts and bad transmission mount and the fact it has a cam in it.

While I was changing the wires one of the ****in terminals came out of the spark plug boot and stayed on the plug, spent 2 hours trying to fix that, ended up having to put a stupid distributor end 90* boot on because the 135* boot ripped and no one near sells the straight terminals, only the 90* ones. And also my high beam switch broke. the lever is just flopping around (turn signals still work and click, but the lever is uncomfortably resting up against the backside of the steering wheel), so I gotta fix that tomorrow.
 
Last edited:
  • Like
Reactions: fleming442
RG383Hurst

RG383Hurst

Not-quite-so-new-guy
Mar 7, 2015
48
33
Finally got the rest of the exhaust mounted up on the chief today.i took a few months away from it, as not having the correct crossmember and headers created some wrong angles and didn’t fit quite right... (forgot to get any pics)

Did however, manage to finally check just how bad the rot on the trunk/back window filler was..... did get a pic of that...
I feel your pain on that pic. I Just replaced the same piece but on the driver side. Also was rot just above the taillight.
 

Please support GBodyForum Sponsors

Classic Truck ConsolesDixie Restoration DepotMike's MontesP-S-TSouthside Machine PerformanceUMI Performance

contact[email protected]for info on becoming a sponsor