1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

strange brakelite problem

Discussion in 'General Discussion' started by cherokeechief79, Jun 26, 2017.

  1. cherokeechief79

    cherokeechief79 Apprentice

    Joined:
    Jul 21, 2008
    Messages:
    94
    Likes Received:
    15
    Trophy Points:
    8
    Location:
    nj
    i fired my new project up last nite and all went well .its an 84 non ss.
    my problem is that the driver side brakelite is on all the time.the pass side works fine as it should though.
    I don't know if was like this before because I didn't have it on the road befor the engine swap and I cant contact the po.
    i did change the steering column from a non to a tilt.
    any ideas?
     
  2. wonderboy24

    wonderboy24 Royal Smart Person

    Joined:
    Jul 10, 2012
    Messages:
    1,050
    Likes Received:
    302
    Trophy Points:
    83
    Location:
    Davenport, Iowa
    could be a bad brake lite switch.
     
  3. cherokeechief79

    cherokeechief79 Apprentice

    Joined:
    Jul 21, 2008
    Messages:
    94
    Likes Received:
    15
    Trophy Points:
    8
    Location:
    nj
    could that make just one side react the way it is?
     
  4. pontiacgp

    pontiacgp Canadian Prime Minister

    Joined:
    Mar 31, 2006
    Messages:
    20,426
    Likes Received:
    2,364
    Trophy Points:
    113
    Location:
    Kitchener, Ontario
    does the turn signal work on the left side?
     
  5. Jeff L

    Jeff L Master Mechanic

    Joined:
    Nov 20, 2016
    Messages:
    351
    Likes Received:
    250
    Trophy Points:
    63
    Location:
    Southern AZ
    Might be some kind of short that is keeping that side activated all the time. I had a similar issue on my Buick Apollo many years ago and if I remember correctly an exposed wire was touching another one that was not covered enough at the switch. What makes me think this might be happening to you is you changed the steering column.

    Recheck you wires and then the switch.
     
    • Agree Agree x 1
  6. tc1959

    tc1959 Comic Book Super Hero

    Joined:
    Dec 23, 2009
    Messages:
    3,485
    Likes Received:
    296
    Trophy Points:
    83
    Location:
    Surprise AZ.
    Change the bulb.
     
    • Agree Agree x 1
  7. 1evilregal

    1evilregal Royal Smart Person

    Joined:
    Apr 23, 2009
    Messages:
    1,684
    Likes Received:
    421
    Trophy Points:
    83
    Location:
    Greensboro, NC
    quite a few GM products use the same power feed for the brakes and turn signals.... I agree with Jeff L, I'd start at the column, since you switched that out.... was it from a same year/model car or different year/model?
     
  8. Jeff L

    Jeff L Master Mechanic

    Joined:
    Nov 20, 2016
    Messages:
    351
    Likes Received:
    250
    Trophy Points:
    63
    Location:
    Southern AZ
    I was talking with a friend of mine about this because he has had experience with electrical problems with all the cars he builds. Some of his suggestions are to check all the lights when you have on the emergency flasher button. Turn off the flashers and try the left and right signals to see what happens. Stop that and see what happens when you put on the brakes. This is to rule out one thing over another. Electrical problems are as frustrating as finding vacuum leaks!

    Some things that can cause issues are the wrong bulb, a short, a bad turn signal stalk, crossed wires, faulty connector, bad brake switch.

    Hope some of this helps.

    Plus did this problem only start after you changed the column? I still think something in there is fouled up.

    Good luck with it.
     
    • Like Like x 1
  9. cherokeechief79

    cherokeechief79 Apprentice

    Joined:
    Jul 21, 2008
    Messages:
    94
    Likes Received:
    15
    Trophy Points:
    8
    Location:
    nj
    just had a chance to look quick last nite at it but heres what I found.
    lites on.......normal pass side brake lite on dr side(appears the wrong filament is on though)
    brakes w key off....pas side ok dr side running lite comes on
    key on....dr blinker blinks but seems to be on the wrong filament.
    emergenct flasher works but driver seems to be on the wrong filament.
    all of the bulbs seem correct and in good shape.sockets too.
     
  10. pontiacgp

    pontiacgp Canadian Prime Minister

    Joined:
    Mar 31, 2006
    Messages:
    20,426
    Likes Received:
    2,364
    Trophy Points:
    113
    Location:
    Kitchener, Ontario
    if the wrong filament is coming on it's either the bulb is in backwards or someone has reversed the wiring
     
    • Like Like x 1
Loading...

Share This Page