CUTLASS 231 v6 coolant sensor

TexasCutlass

Apprentice
Sep 22, 2020
51
18
85 cutlass with the 231 3.8 v6. I am getting a code 15, I turn the car on and after about 5 minutes the check engine light comes on. I've replaced the temperature switch but I'm lost on the temperature sensor. My car has what I'm assuming is the sensor located on the front center of the engine. It doesn't look like the 2 pin sensor it has a white plastic nipple but there isn't a plug on it. I've searched everywhere for something that looks like would plug into it but I see nothing. Auto parts and internet keep showing me the black 2 pin sensor. Anybody have pics of there sensor and plug or can I make the 2 pin sensor work?
20200923_171957.jpg
20200923_172035.jpg
 

TexasCutlass

Apprentice
Thread starter
Sep 22, 2020
51
18
This is what my car has, is that the temp sensor? Auto parts don't have it and when I search the internet I still can't find it. I don't even see a plug that would go on that or what it looks like.
20200923_185618.jpg
 
G-Body Performance Upgrades

GBodyForum is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.

Please support GBodyForum Sponsors

Classic Truck ConsolesDixie Restoration DepotMike's MontesP-S-TSouthside Machine PerformanceUMI Performance

contact[email protected]for info on becoming a sponsor