What Would You Do - GMT800 Starter...

ed1948

ed1948

Royal Smart Person
Aug 6, 2016
1,248
113
Toronto
Rebuilt starter, roughly a month old - stopped working, now works again.
Re: 2006 GM Sierra Z71 4x4
I installed a rebuilt starter to correct a weak solenoid (no click) issue. Battery is new, ground wires were all re done, 12 V wire to starter is good. Rebuilt starter has about 30 start cycles.
Last week I drove in a snow storm where temps were 10*F and then parked the truck outside overnight. Next morning all I heard was click - no starter action. I repeated the start attempt 20 times. Battery voltage was 12.1V. Even with a booster pack it would do no more than a single click. Next morning when the temperature was again 5 -8*F I again tried to start - first was click, second the starter turned and the engine started. Since then, in order to test it, I removed the fuel pump relay and so far, have cranked it around 40 times without failure.

The starter is still under warranty and can exchange it without problems.
The question: Can I assume it may have been a fluke the starter refused to crank and it will work from now? Or should I just exchange it(I hate working outside in the cold weather) and spend an hour of my time screwing in a newly rebuilt unit?
Pic of the original starter....
\
P1140748.JPG
 
Streetbu

Streetbu

Royal Smart Person
Supporting Member
May 22, 2011
1,122
113
Central NY
Return it...
 
Gwarren79

Gwarren79

Master Mechanic
Oct 29, 2018
255
63
Safford, AZ
So you replace the starter when you had a "no-click" issue, and now have a "no-click" issue and you think both starters were bad when the did the exact same thing?
 
ed1948

ed1948

Royal Smart Person
Aug 6, 2016
1,248
113
Toronto
Gwarren79

The original starter had no click, no crank. This replacement has click, no crank. I suspect the rebuild has either a sticky solenoid contact or a dead spot on the armature. The problem is it works every time now but can it be trusted? Looks will be warm enough to get under the truck today.
I'd rather work on the Monte - door window switch is not working intermittently.
 
Texas82GP

Texas82GP

Comic Book Super Hero
Supporting Member
Apr 3, 2015
4,983
113
Spring, Texas
Replace the start relay first; the Omnicrons are turds.
I recommend doing this first. The last time I replaced a starter on one of these, I used a Delco new starter and was very happy with it....
Screenshot_20190204-103836_Samsung Internet.jpg
 
ed1948

ed1948

Royal Smart Person
Aug 6, 2016
1,248
113
Toronto
Confirmed voltage drop is minimal (less than .2 V at supply and ground). Starter is ordered. At least it's 5*C on the driveway. We are in between Polar Vortexes.
 

Please support GBodyForum Sponsors

Classic Truck ConsolesDixie Restoration DepotMike's MontesP-S-TSouthside Machine PerformanceUMI Performance

contact[email protected]for info on becoming a sponsor