Turn signal problems...need help!

Discussion in 'Electrical' started by Mahlon Entz, Sep 17, 2017.

  1. Mahlon Entz

    Mahlon Entz Not-quite-so-new-guy

    Joined:
    Sep 17, 2017
    Messages:
    19
    Likes Received:
    12
    Trophy Points:
    3
    Location:
    erie
    Lights and 4 ways are working on my 79 regal sport coupe but i have no turn signals. I checked my blinker relay and it's good, no power even reaching it after checking with a test light. Any ideas on what the problem is??
     
  2. Slowpoke

    Slowpoke G-Body Guru

    Joined:
    Dec 23, 2016
    Messages:
    555
    Likes Received:
    710
    Trophy Points:
    93
    I'm sure someone will chime in. An introduction would be nice.
     
    • Agree Agree x 2
  3. Mahlon Entz

    Mahlon Entz Not-quite-so-new-guy

    Joined:
    Sep 17, 2017
    Messages:
    19
    Likes Received:
    12
    Trophy Points:
    3
    Location:
    erie
    I'm tex. Live up in erie pa.
    Just swapped my pick-up for a regal with a transplanted 305. It needs tlc, alot of interior and some body work. It was already gutted for floorpan replacement when i got it. Really excited about turning this into a street beast but as i said before, this electrical issue has me stumped.
     
  4. Slowpoke

    Slowpoke G-Body Guru

    Joined:
    Dec 23, 2016
    Messages:
    555
    Likes Received:
    710
    Trophy Points:
    93
    Sweet I have a regal as well.. Not sure what your problem is , but there is a ton of knowledgeable people in here.. They will get you right! Hope you stick around.. And a big welcome to the best gbody site .
     
  5. Mahlon Entz

    Mahlon Entz Not-quite-so-new-guy

    Joined:
    Sep 17, 2017
    Messages:
    19
    Likes Received:
    12
    Trophy Points:
    3
    Location:
    erie
    Thanks man, i really appreciate it! I hope i get some direction in this one!
    If i knew how to send a pic i would..
     

    Attached Files:

  6. Slowpoke

    Slowpoke G-Body Guru

    Joined:
    Dec 23, 2016
    Messages:
    555
    Likes Received:
    710
    Trophy Points:
    93
    Have you checked the harness going into the column itself? Making sure good contact? Make sure you have the correct bulbs in there too
     
  7. Mahlon Entz

    Mahlon Entz Not-quite-so-new-guy

    Joined:
    Sep 17, 2017
    Messages:
    19
    Likes Received:
    12
    Trophy Points:
    3
    Location:
    erie
     
  8. Slowpoke

    Slowpoke G-Body Guru

    Joined:
    Dec 23, 2016
    Messages:
    555
    Likes Received:
    710
    Trophy Points:
    93
    You'd be surprised what a wrong bulb will do.. I'm assuming you have checked with a light tester on the harness with outv the bulb?
     
  9. pagrunt

    pagrunt Royal Smart Person

    Joined:
    Sep 14, 2014
    Messages:
    1,889
    Likes Received:
    810
    Trophy Points:
    113
    Location:
    Shelocta, Pa
    Check the conector between the tail light & the front to rear harness. There could be corrosion there.
     
  10. airboatgreg

    airboatgreg G-Body Guru

    Joined:
    Oct 2, 2016
    Messages:
    842
    Likes Received:
    525
    Trophy Points:
    93
    Swap 4 way flasher with turn signal flasher first
     
Loading...
Similar Threads - Turn signal problems Forum Date
87 Olds Headlights/Turn Signal Problemss Electrical Mar 22, 2014
Column swap turn signal switch confusion Electrical May 25, 2018
CUTLASS 1987 olds turn signal help Electrical Mar 24, 2018
Turn signal switch won't lock to right. Electrical Mar 11, 2018
Turn signals flash like hazards Electrical Oct 28, 2017

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice